Bashhub — открывает доступ к истории терминала из любой точки

Если у вас настроен роутер Mikrotik со статическим IP адресом и вам нужен удаленный доступ к нему для администрирования? Вот две простых инструкции по настройке доступа на RouterOS.

Как добавить программу от неустановленного разработчика в исключения

  1. Нажмите на клавиатуре ^Control и, удерживая ее, кликните по программе, которую хотите открыть или просто кликните по ней правой клавишей мыши
  2. Перед вами появится контекстное меню, выберите пункт Открыть
  3. Теперь нажмите кнопку Открыть

После проделанных шагов программа откроется и будет добавлена в список исключений. В дальнейшем Вы сможете открывать ее как и любую другую программу, простым двойным щелчком мыши.

Надеемся данный материал был полезен для вас. Если да, то расскажите об этом и своим друзьями, поделитесь с ними ссылкой на статью в социальных сетях. Также присоединяйся к нам в Facebook, Twitter, Вконтакте и находите еще больше полезных советов

Настройка доступа через терминал

Запускаем winbox, скачать можно с официального сайта и запускаем терминал

В терминале по очереди вводим команды:

/ip firewall filter add chain=input protocol=tcp dst-port=8291 disabled=no action=accept place-before 0

Этим правилом мы разрешим доступ для входящего трафика на порт 8291 из вне. И поднимаем это правило в верх всех правил фаервола.

/ip service set winbox address=0.0.0.0/0

А этим правилом, мы разрешаем любые подключения на роутер из интернета.

Важно! В целях безопасности и для защиты роутера от подбора паролей рекомендуется открывать доступ только для надежных подсетей или ip адресов!

Читайте также:  Git — распределённая система контроля версий: базовые настройка

Поэтому я не рекомендую использовать вышеуказанное правило, а рекомендую использовать для входа только разрешенные адреса и следующее правило.

/ip service set winbox address=

Где — адрес локальной сети

Настройка доступа через терминал

А и — адреса из сети интернет

Эти данные необходимо заменить на свои.

Командная оболочка Bash

В bash имеется несколько приемов для работы со строкой команд. Например, используя клавиатуру, можно:

  • Ctrl + A — перейти на начало строки.
  • Ctrl + U — удалить текущую строку.
  • Ctrl + C — остановить текущую задачу.

Можно использовать «;» для того, чтобы ввести несколько команд одной строкой. Клавиши «вверх» и «вниз», позволяют вам перемещаться по истории команд. Для того чтобы найти конкретную команду в списке набранных, не пролистывая всю историю, необходимо набрать:

Ctrl + R

Команды, присутствующие в истории, отображаются в списке пронумерованными. Для того, чтобы запустить конкретную команду, наберите:

! номер команды

если ввести:

запустится последняя из набранных команд.

Иногда имена программ и команд слишком длинны. Bash сам может завершать имена. Нажав клавишу [TAB], можно завершить имя команды, программы или каталога. Например, предположим, что необходимо использовать программу декомпрессии bunzip2. Для этого нужно набрать:

затем нажать [TAB]. Если ничего не происходит, то, вероятно, существует несколько возможных вариантов завершения команды.

Нажав клавишу [TAB] еще раз, пользователь получит список имен, начинающихся с «bu».

Например, может быть:

$ bu buildhash builtin bunzip2

Если далее добавить:

(bunzip — это единственное имя, третьей буквой которого является «n»), а затем нажать клавишу [TAB], оболочка дополнит имя и остается лишь нажать «Enter», чтобы запустить команду.

Программу, вызываемую из командной строки, Bash ищет в каталогах, определяемых в системной переменной PATH. По умолчанию, в этот перечень каталогов не входит текущий каталог, обозначаемый «./» (точка слэш),  поэтому для запуска программы prog из текущего каталога, надо дать команду:

Читайте также:  Как установить андроид-приложения на windows phone

./prog

Как создать резервную копию почтового ящика The Bat

Как уже оговаривалось в предыдущем разделе, каждому почтовому профилю, который подключен к почтовому клиенту The Bat, соответствует отдельная папка. Данная папка содержит набор файлов с настройками пользователя, и данными сообщений конкретного почтового ящика. В нашем случае, как видно из скриншота, к почтовому клиенту подключено два почтовых ящика c названиями «» и «».

Есть два способа создания резервной копии данных почтового ящика:

Cоздать копию папки вручную

Можно создать копию базы данных почтовых пересылок вручную и сохранить её в другое место. В случае переустановки Windows, или форматирования жесткого диска с последующей переустановкой The Bat, данные папки можно будет перенести обратно в папку с данными почтового клиента.

Для этого:

  • после установки программы, при первом запуске не создавайте новый почтовый ящик, а закройте The Bat.

  • Перейдите в папку с данными почтового клиента C:\Users\ИмяПользователя\AppData\Roaming\The Bat! и перенесите в неё созданные раннее копии папок почтовых ящиков.

  • Теперь, после запуска, The Bat не будет требовать создание нового почтового ящика, а загрузит данные из скопированных папок, которые по сути являются папками профилей почтовых ящиков.

С помощью функции The Bat «Резервная копия…» (*.TBK)

В The Bat есть встроенный инструмент резервирования данных почтового клиента. Чтобы создать резервную копию данных вашего почтового ящика с помощью The Bat:

  • Перейдите в меню Инструменты / Резервная копия…

  • В открывшемся окне укажите данные, резервную копию которых необходимо создать, и задайте имя и место сохранения файла архива.

  • Укажите почтовые ящики, донные которых необходимо резервировать и защитите архив паролем (в случае необходимости).

В результате, в указанной при создании архива папке будет создан файл архива с установленным пользователем названием и расширением *.TBK.

Восстановить данные почтового ящика из резервной копии можно с помощью функции «Восстановить из резервной копии…». Для этого достаточно выбрать Инструменты / Восстановить из резервной копии… и указать почтовому клиенту место расположения файла архива.

Закрытие файла

Метод close()

После открытия файла в Python его нужно закрыть. Таким образом освобождаются ресурсы и убирается мусор. Python автоматически закрывает файл, когда объект присваивается другому файлу.

Существуют следующие способы:

Способ №1

Проще всего после открытия файла закрыть его, используя метод close().

f = open(»,‘r’) # работа с файлом f.close()

Закрытие файла

После закрытия этот файл нельзя будет использовать до тех пор, пока заново его не открыть.

Способ №2

Также можно написать try/finally, которое гарантирует, что если после открытия файла операции с ним приводят к исключениям, он закроется автоматически.

Без него программа завершается некорректно.

Вот как сделать это исключение:

f = open(»,‘r’) try: # работа с файлом finally: f.close()

Файл нужно открыть до инструкции try, потому что если инструкция open сама по себе вызовет ошибку, то файл не будет открываться для последующего закрытия.

Этот метод гарантирует, что если операции над файлом вызовут исключения, то он закроется до того как программа остановится.

Способ №3

Инструкция with

Закрытие файла

Еще один подход — использовать инструкцию with, которая упрощает обработку исключений с помощью инкапсуляции начальных операций, а также задач по закрытию и очистке.

В таком случае инструкция close не нужна, потому что with автоматически закроет файл.

Вот как это реализовать в коде.

with open(») as f: # работа с файлом